Home
last modified time | relevance | path

Searched refs:composer (Results 1 – 25 of 196) sorted by relevance

12345678

/plugin/jplayer/vendor/robloach/component-installer/src/ComponentInstaller/Process/
H A DProcess.php31 protected $composer; variable in ComponentInstaller\\Process\\Process
67 public function __construct(Composer $composer = null, IOInterface $io = null) argument
69 $this->composer = isset($composer) ? $composer : new Composer();
72 $this->installationManager = $this->composer->getInstallationManager();
81 $this->config = $this->composer->getConfig();
91 $locker = $this->composer->getLocker();
106 $rootPackage = $this->composer->getPackage();
124 $root = $this->composer->getPackage();
H A DProcessInterface.php22 * @param Composer $composer
27 public function __construct(Composer $composer, IOInterface $io); argument
/plugin/elasticsearch/vendor/guzzlehttp/ringphp/
H A D.travis.yml5 - $HOME/.composer/cache/files
19 - TEST_COMMAND="composer test"
34 # To be removed when this issue will be resolved: https://github.com/composer/composer/issues/5355
35 …- if [[ "$COMPOSER_FLAGS" == *"--prefer-lowest"* ]]; then travis_retry composer update --prefer-di…
36 - travis_retry composer update ${COMPOSER_FLAGS} --prefer-dist --no-interaction
/plugin/quickstats/GEOIP/vendor/composer/ca-bundle/
H A DREADME.md1 composer/ca-bundle
7 Originally written as part of [composer/composer](https://github.com/composer/composer),
17 $ composer require composer/ca-bundle
85 composer/ca-bundle is licensed under the MIT License, see the LICENSE file for details.
/plugin/elasticsearch/vendor/elasticsearch/elasticsearch/
H A D.travis.yml35 - composer install --prefer-dist
43 - if [ $TRAVIS_PHP_VERSION != '7.3' ]; then composer run-script phpcs; fi
44 - if [ $TRAVIS_PHP_VERSION = '7.1' ]; then composer run-script phpstan7.1; fi
45 - if [ $TRAVIS_PHP_VERSION = '7.2' ]; then composer run-script phpstan7.1; fi
46 - if [ $TRAVIS_PHP_VERSION = '7.3' ]; then composer run-script phpstan; fi
/plugin/jplayer/vendor/robloach/component-installer/src/ComponentInstaller/
H A DInstaller.php41 $rootPackage = isset($this->composer) ? $this->composer->getPackage() : null;
79 $rootPackage = $this->composer->getPackage();
115 $config = $this->composer->getConfig();
162 $composer = $event->getComposer();
186 $process = new $class($composer, $io);
H A DComponentInstallerPlugin.php30 public function activate(Composer $composer, IOInterface $io) argument
32 $installer = new Installer($io, $composer);
33 $composer->getInstallationManager()->addInstaller($installer);
/plugin/mdpage/vendor/cebe/markdown/
H A D.travis.yml19 # cache composer cache
22 - $HOME/.composer/cache
32 - composer self-update && composer --version
33 - composer install --prefer-dist
/plugin/findologicxmlexport/vendor/sebastian/object-enumerator/
H A D.travis.yml12 - composer self-update
13 - composer clear-cache
16 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/findologicxmlexport/vendor/phpunit/php-timer/
H A D.travis.yml17 - composer self-update
18 - composer clear-cache
21 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/findologicxmlexport/vendor/sebastian/code-unit-reverse-lookup/
H A D.travis.yml14 - composer self-update
15 - composer clear-cache
18 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/findologicxmlexport/vendor/phpunit/php-token-stream/
H A D.travis.yml12 - composer self-update
13 - composer clear-cache
16 - travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest
/plugin/findologicxmlexport/vendor/phpunit/phpunit-mock-objects/
H A D.travis.yml14 - composer self-update
15 - composer clear-cache
18 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/findologicxmlexport/vendor/sebastian/diff/
H A D.travis.yml17 - composer self-update
18 - composer clear-cache
21 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/authgooglesheets/vendor/guzzlehttp/guzzle/
H A DDockerfile1 FROM composer:latest as setup
8 …&& composer init --name=guzzlehttp/test --description="Simple project for testing Guzzle scripts" …
9 && composer require guzzlehttp/guzzle
/plugin/findologicxmlexport/vendor/twig/extensions/
H A D.travis.yml8 - $HOME/.composer/cache/files
17 - if [ "$DEPS" == "low" ]; then composer --prefer-lowest --prefer-stable update; fi;
18 - if [ "$DEPS" == "no" ]; then composer install; fi;
/plugin/findologicxmlexport/vendor/phpdocumentor/reflection-common/
H A D.travis.yml18 - $HOME/.composer/cache
22 - composer update --no-interaction --prefer-source
26 - composer install --no-interaction
/plugin/findologicxmlexport/vendor/jms/metadata/
H A D.travis.yml10 - $HOME/.composer/cache
22 - composer self-update
23 - composer update $COMPOSER_FLAGS
/plugin/findologicxmlexport/vendor/phpunit/phpunit/
H A D.travis.yml31 - composer self-update
32 - composer clear-cache
35 - if [[ "$DEPENDENCIES" = 'high' ]]; then travis_retry composer update $DEFAULT_COMPOSER_FLAGS; fi
36 …- if [[ "$DEPENDENCIES" = 'low' ]]; then travis_retry composer update $DEFAULT_COMPOSER_FLAGS --pr…
/plugin/findologicxmlexport/vendor/goetas-webservices/xsd2php-runtime/
H A D.travis.yml6 - $HOME/.composer/cache
22 - composer self-update
23 - composer update $COMPOSER_FLAGS
/plugin/findologicxmlexport/vendor/phpunit/php-code-coverage/
H A D.travis.yml27 - composer self-update
28 - composer clear-cache
31 …- travis_retry composer update --no-interaction --no-ansi --no-progress --no-suggest --optimize-au…
/plugin/findologicxmlexport/vendor/jms/serializer/.travis/
H A Dinstall_test.sh5 composer self-update
6 composer update $COMPOSER_FLAGS -n
/plugin/davcard/vendor/sabre/vobject/
H A DREADME.md24 VObject requires PHP 5.3, and should be installed using composer.
25 The general composer instructions can be found on the [composer website](http://getcomposer.org/doc…
33 Then, run `composer.phar update` and you should be good.
/plugin/davcal/vendor/sabre/vobject/
H A DREADME.md24 VObject requires PHP 5.3, and should be installed using composer.
25 The general composer instructions can be found on the [composer website](http://getcomposer.org/doc…
33 Then, run `composer.phar update` and you should be good.
/plugin/webdavclient/vendor/sabre/vobject/
H A DREADME.md24 VObject requires PHP 5.3, and should be installed using composer.
25 The general composer instructions can be found on the [composer website](http://getcomposer.org/doc…
33 Then, run `composer.phar update` and you should be good.

12345678